PropertyBoost: Chrome users unable to purchase boost
Incident Report for Inside Real Estate
Resolved
This PropertyBoost incident has been resolved
Posted 21 days ago. Jun 24, 2019 - 16:40 MDT
Update
We've identified the issue with PropertyBoost as being with our payment processor and affecting the latest version of Chrome. We are working on a solution.
Posted 22 days ago. Jun 24, 2019 - 13:37 MDT
Investigating
We are currently investigating an issue where PropertyBoost users are unable to purchase boosts using Google Chrome.
Posted 22 days ago. Jun 24, 2019 - 09:59 MDT
This incident affected: CORE Property Boost.